Full service web hosting, great prices and support. Starts at $1.99/month!
Results 1 to 5 of 5

Thread: Order received, but looks as if it is sent by server?

  1. #1
    countingsheep
    Guest


    Default Order received, but looks as if it is sent by server?

    My client received an order that resulted in the following:


    email links changed in message below:

    -----Original Message-----
    From: nobody@server.serversite.com
    [mailto:nobody@server.serversite.com] On Behalf Of
    client@theirwebaddress.com


    What do I need to look for to get this configured correctly?

  2. #2
    countingsheep
    Guest


    Default Re: Order received, but looks as if it is sent by server?

    We have yet to find where to correct this.. can anyone offer a suggestion please on what I need to be looking for??
    ~~~~~~~~~~~~~~~
    When an order is placed, I receive a copy from
    hername@website.com. I also receive the email below from nobody.
    What is this about?

    HerName



    -----Original Message-----
    From: nobody@black.countingsheepwebdesigns.com
    [mailto:nobody@black.countingsheepwebdesigns.com] On Behalf Of
    HerName@website.com
    Sent: Thursday, April 19, 2007 8:00 PM
    To: hername; Her Name Again
    Subject: Order Process

  3. #3
    osCMax Developer


    Order received, but looks as if it is sent by server?


    Join Date
    Jul 2002
    Location
    Phoenix, AZ
    Posts
    23,134
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    michael_s     $ 10.00
    Rep Power
    597


    Default Re: Order received, but looks as if it is sent by server?


  4. #4
    countingsheep
    Guest


    Default Re: Order received, but looks as if it is sent by server?

    I would have never found that because of the difference in terminology. But this is based on version 3.0 and her cart is using v2.0. i found the line in general.php :
    $from_email_name = preg_replace('/[\n|\r].*/', '', $from_email);
    on line 1014
    and changed it to:
    $from_email_name = preg_replace('/[\n|\r].*/', '', $from_email_name);

    This didnt remedy the problem and no one else is having this problem and all others are using this same cart as well as being on the same server, and I have never had to do this prior to that. Is it possible that it could be something to do with her server instead?

    I added myself to receive the email for orders as well and I do not see that nobody@email.com in the order I receive as a customer nor as a store owner.
    Last edited by countingsheep; 05-10-2007 at 05:53 PM.

  5. #5
    osCMax Developer


    Order received, but looks as if it is sent by server?


    Join Date
    Jul 2002
    Location
    Phoenix, AZ
    Posts
    23,134
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    michael_s     $ 10.00
    Rep Power
    597


    Default Re: Order received, but looks as if it is sent by server?

    If you do a basic search on 'email'

    it pops right up. Perhaps you need to revisit how to do searches... First, very general search terms then narrow it down if you get too many results.

    So, since this has to do with email, it seems to make sense to me that your first search would be to look for all bugs relating to 'email' . I don't keep all the bugfixes committed to memory, so that is how I found it.

    If that does not fix the issue, you probably just have the email address formatted incorrectly in your admin panel.

    The email from needs to be in this format:

    Your Mail <admin@yourshop.com>

    It needs the < > around the email address.

Similar Threads

  1. Email notifications not received anymore
    By ozstar in forum osCmax v2 Installation issues
    Replies: 1
    Last Post: 10-13-2006, 04:16 AM
  2. authorize.net emails not received
    By Christy in forum osCmax v2 Customization/Mods
    Replies: 2
    Last Post: 04-08-2006, 08:02 AM
  3. Error received when accepting payment through authorize.net
    By bbsemail in forum osCommerce 2.2 Installation Help
    Replies: 3
    Last Post: 02-07-2005, 08:52 AM
  4. customer comments in order and extra order email
    By karen_l in forum osCommerce 2.2 Modification Help
    Replies: 0
    Last Post: 01-03-2003, 11:51 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •