Full service web hosting, great prices and support. Starts at $1.99/month!
Results 1 to 9 of 9

Thread: USPS Module First Class Large Envelope not showing at checkout

  1. #1
    tschmitt0102
    Guest


    Question USPS Module First Class Large Envelope not showing at checkout

    Using the USPS module, I have every domestic shipping option checked and most will show up when you go to checkout, but based on the dimensions and weight of the product being tested for shipping the First Class Large Envelope option should show as a shipping option. The product dimensions are length = 11, height = .25, width = .25 with First Class Large Envelope set to length = 15, width = 12, thickness = .75, so the dimensions should work with First Class Large Envelope. The weight of the product is set to .25 for 4 ounces and the module weight for First Class Large Envelope is set to 13 ounces. So both dimensions and weight fit the criteria for First Class Large Envelope, but this option is still not showing when one goes to checkout. I having been searching around forums and have been unable to find any probable solution or explanation as to why the problem is occurring. Any help would be appreciated, as this is the last item I need to complete to get my shop operational. Thanks in advance.

  2. #2
    osCMax Development Team

    USPS Module First Class Large Envelope not showing at checkout

    pgmarshall's Avatar
    Join Date
    Feb 2009
    Location
    London
    Posts
    3,517
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    pgmarshall     $ 35.00
    Rep Power
    80


    Default Re: USPS Module First Class Large Envelope not showing at checkout

    If you are using customer groups then make sure the module is enabled for the customer group.

    Check the module is enabled for the zones you have set up.

    Otherwise you will need to step through the payment module to see why it is not being enabled.

    Regards.
    pgmarshall
    _______________________________

  3. #3
    tschmitt0102
    Guest


    Default Re: USPS Module First Class Large Envelope not showing at checkout

    I looked into the customer groups and both had already been set to use the USPS module. Shipping zones is set to "None" and only has Florida in the module menu drop-down for this option. I was not sure if you meant to say "payment module" or "shipping module", so I checked both. The payment module does not have anything related to shipping, so I am not sure what to look for in the payment module. The shipping module has the First-Class Large Envelope option checked with a set max weight of 13 ounces, which the item is under. I eliminated tare weight from the weight calculation for shipping, so now the weight displayed in the shipping calculation is now correct but still failing to show First-Class as an option. Shipping is currently showing these as my shipping options (in this order) for the test product:

    Express Mail
    Priority Mail Large Flat Rate Box
    Parcel Post
    Priority Mail
    Media Mail
    Library Mail

    Could it be the usps.php file in catalog/includes/modules? Or maybe a problem with the module version? Any further assistance would be helpful.

    Alright, so I unchecked everything but the First-Class Large Envelope box and now I am receiving this error: -2147219085 Invalid XML Element content is incomplete according to the DTD/Schema. line= 0 pos= 1668. Any thoughts?

    Quote Originally Posted by pgmarshall View Post
    If you are using customer groups then make sure the module is enabled for the customer group.

    Check the module is enabled for the zones you have set up.

    Otherwise you will need to step through the payment module to see why it is not being enabled.

    Regards.
    Last edited by tschmitt0102; 05-31-2012 at 11:47 AM.

  4. #4
    osCMax Development Team

    USPS Module First Class Large Envelope not showing at checkout

    pgmarshall's Avatar
    Join Date
    Feb 2009
    Location
    London
    Posts
    3,517
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    pgmarshall     $ 35.00
    Rep Power
    80


    Default Re: USPS Module First Class Large Envelope not showing at checkout

    Try reading this ... USPS Rate V4, Intl Rate V2 (official support thread) - osCommerce Support Forum - Page 8

    Not sure if there is a solution posted ...

    Regards.
    pgmarshall
    _______________________________

  5. #5
    ozdunker
    Guest


    Default Re: USPS Module First Class Large Envelope not showing at checkout

    First class mail is not working.
    On the earlier module First class mail was working, however the markup wasnt working for it.

    On this new module it is not working at all.

    I actually prefer the old module as you could specifiy what type of postage would be available based on weight. I only upgraded because I was hoping the have the first class section working.

  6. #6
    ozdunker
    Guest


    Default Re: USPS Module First Class Large Envelope not showing at checkout

    The new module is also causing these sorts of errors on the email invoices, pdf invoices etc

    United States Postal Service  (Priority Mail® Legal Flat Rate Envelope
    United States Postal Service  (Express Mail® International Flat Rate Envelope------Approx. delivery time 3 - 5 MODULE_SHIPPING_USPS_TEXT_BUSINESS Days):

  7. #7
    osCMax Development Team

    USPS Module First Class Large Envelope not showing at checkout

    pgmarshall's Avatar
    Join Date
    Feb 2009
    Location
    London
    Posts
    3,517
    Contribute If you enjoy reading the
    content here, click the below
    image to support our site.
    Click Here To Contribute To Our Site

    Total Contributions For

    pgmarshall     $ 35.00
    Rep Power
    80


    Default Re: USPS Module First Class Large Envelope not showing at checkout

    Have you got your mail settings set to HTML emails using MIME?

    Regards.
    pgmarshall
    _______________________________

  8. #8
    ozdunker
    Guest


    Default Re: USPS Module First Class Large Envelope not showing at checkout

    hi
    Use MIME HTML When Sending Emails false
    I have never changed this.
    Should I change this.
    It was fine with the previous module.
    Last edited by ozdunker; 06-22-2012 at 09:16 AM.

  9. #9
    ozdunker
    Guest


    Default Re: USPS Module First Class Large Envelope not showing at checkout

    actually I think I know what the issue probably is - the is now a registered symbol (Priority Mail® Legal Flat Rate Envelope) showing in the store. I guess this ® is causing the &reg error?

Similar Threads

  1. [Admin Issue] Shipping USPS/UPS XML not showing up
    By MrE03 in forum Bugs and Problems
    Replies: 9
    Last Post: 05-09-2011, 06:14 PM
  2. USPS Backup Module (When USPS Goes Down...)
    By michael_s in forum New osCommerce Contributions
    Replies: 0
    Last Post: 12-10-2008, 03:11 AM
  3. Shipping module not showing on checkout
    By rjavery in forum Table Rate
    Replies: 2
    Last Post: 06-15-2007, 11:19 PM
  4. Pushing the Envelope ?
    By ashelleydesign in forum osCmax v2 Customization/Mods
    Replies: 0
    Last Post: 01-21-2007, 08:31 AM
  5. USPS Module - Airmail Letter Not Showing Up
    By reggiman1 in forum osCMax v1.7 General Mods Discussion
    Replies: 0
    Last Post: 06-10-2005, 09:08 AM

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •