View Full Version : port, checkout_process, or domain issue?

02-10-2007, 10:00 AM
I have a client running max 2.2 who is also planning to use paypal ipn and has attempted to install it. His main processor is linkpoint. I hardcoded the linkpointms1.php file with his store number and 50% of the time the payment would process with wrong expir date in testing, the other 50% of the time there was a connection error in explorer (timeouts). I had the host ensure that port 1129 was open and then 100% of the time the transaction would not process. I installed the newest linkpoint api that requires ssl but does not offer the cvv check. It failed. The pem file is coming from an original domain and we are trying to use the max module and that pem file on two different domains. Is linkpoint kicking it out because of the domain not being the original domain for the original pem?????

My host says this:

"Regarding your linkpoint access, I found that port 1129 is required and enabled port 1129 on our servers firewall. Note that we were not able to complete the transaction even after that because checkout_process.php was found to be asked for download instead of processing the credit card detalis entered after checkout. No idea what is going wrong here. Could you please check with your script provider and find if they have any fix for this."

Please help -- I am going to trouble shoot overwriting the checkout_process page with a fresh one though I did not alter it and also try to start clean with the oscmax linkpoint mod as well. I will also try to ensure that the cart is upgraded for the paypal bug... Any advice would be greatly appreciated as to how to troubleshoot for the host, the mod, or linkpoint.

thanks in advance.

02-11-2007, 06:09 AM
This looks like an issue with your host/server configuration. Linkpoint and Payapal should not effect each other, and I cannot reproduce this issue on our test server.

The download issue is usually due to php running out of memory, either because the memory limit in php is set too low, or there is not enough ram on the machine.

02-11-2007, 02:54 PM
Thank you for the info. I appreciate you.


02-13-2007, 08:07 AM

The host changed the memory from 8 to 16 and port 1129 is confirmed open. Neither the newest api or the preinstalled linkpoint mod work yet. Instead of a connection diagnosis error, now I am getting a http 406 error. I have checked the config files (my ssl is set to https://domain.com not www) I told Internet explorer to dump encrypted files as suggested by the error message -- is it a chmod issue or any other ideas? were there any changes to the lpphp file needed or anything else you can think of as to why I am still getting this error? is it because the pem file was generated for a completely different domain or no? I'm at a loss as it worked 50% of the time for a short while...

thank you for any guidance you can provide me.

02-13-2007, 08:10 AM
oh -- i also ran across this but just don't know if that is barking up the wrong tree or not...:

The problem is within the URL which is called for the credit card module...

The 'cc ' at the end is being picked up by mod_security as it's also the linux command to run the compiler. If we allowed this, it's possible that a hacker could compile or recompile programs by entering a specifically coded URL. Unfortunately this clashes with os-commerce.

please advise me.

02-13-2007, 08:43 AM
406 error means that your host has mod_security installed and it is blocking the connection.

I am running mod_security on all my servers, and do not have this problem, and I run a very extensive ruleset.

If you disable compilers for non-privileged users, this will preclude the need for mod_security rules blocking it.

This is primarily a server management issue, and not an osCMax issue.