View Full Version : Authorize.net Error

12-21-2009, 02:13 PM
When I try to place an order in Live mode with my own real credit card, I get the following non-descript error message:

There has been an error processing your credit card

Please try again and if problems persist, please try another payment method.

The thing is the charge IS getting through to Authorize.net and being approved. I just cant finish the order process in checkout. I resolved my other issues in another thread and can checkout with Money Order, COD, and Paypal(it takes me to Paypal.com but I have not set up the Paypal payment module to work with my Paypal account yet).

I currently have the Authorize.net payment module set with the following settings. I have the correct Login ID and Transaction Key set. I have MD5 Hash setup with a 32 character code/password. Transaction Server is set to Live. Transaction Mode set to Live. Transaction Method set to Authorization. Curl box I left blank.

Anyone have a similar problem or suggestions?

12-22-2009, 05:35 PM
that's usually happens if you are using SIM and waited too long to process the order form on authorizes' page.

12-28-2009, 05:25 PM
OK< and unanswered post...and the original poster never returned.


Could?? It have anything to do with this?

I am so brain dead over all this...it is pitiful

authorize.net problems - osCommerce Community Support Forums (http://forums.oscommerce.com/topic/293398-authorize-net-problems/page__p__1280555__hl__checkout_paymentphppayment_e rror__fromsearch__1&#entry1280555)

12-30-2009, 10:21 AM
that's usually happens if you are using SIM and waited too long to process the order form on authorizes' page.

Hello BH, and happy holidays from Wisconsin.

It was mentioned to me by pgm that you possibly are using AuthNet. I looked back thru a SIM post you made...there were no responses...

I also see later posts where you're doing Paypal now also.

Have you successfully been able to do a transaction with the CC AIM please?

And if so...I am am wondering what version please?


12-30-2009, 10:31 AM
sup trochia (http://www.oscmax.com/forums/members/trochia.html)
I apologize, I'm not using the AIM or tested with AIM, but instead using SIM which is working great for my customers as long as they don't get all the way to the form page that filles out their credit card info and wait longer than 5 minutes to submit that page. Outside of that, SIM is working great for me.

Yes using Authorize SIM with Paypal, and check/money order and now trying to integrate echeck, all on oscmax 2.0.4


12-30-2009, 10:34 AM
Hey BH, thx for the reply...and the heads up on the SIM...

Fast question back to you? You are using 2.0.3 or 2.0.4?


12-30-2009, 10:53 AM
OK, For the first time...swung and trying SIM "out of the box" on 2.0.4 after a week of AIM with no results....As I had successfully for quite some time been running shop for 11 months w/out a single problem in 2.0RC3 of ocCMax.

a) It is (SIM) is the only module I have installed

b) I am at:
Payment Method http://mynotify1.com/cart/images/pixel_trans.gif This is currently the only payment method available to use on this order. http://mynotify1.com/cart/images/pixel_trans.gif http://mynotify1.com/cart/images/pixel_trans.gif http://mynotify1.com/cart/images/pixel_trans.gif Credit Card (Processed by Authorize.net)c) Continue
to confirm this order.

d) I do this and returned > checkout_confirmation.php

e) There is no place for entering the CC info?

f) Pressing Confirm results =

The following errors have occurred.

(14) The referrer, relay response or receipt link URL is invalid.

and > https://secure.authorize.net/gateway/transact.dll in URL bar.

And yes, Authnet info is all correct..

I also tried going into the Customer Details and set >
Authorize.net Credit Card SIM

And I get the same results?

Thx again,


12-30-2009, 11:15 AM

It should not matter if you are using v2.0.3 or v2.0.4 as the only changes between these versions was the removal of the following files from the admin section.


However, I think you are using 2.0RC3 which is quite old now ... and different from 2.0.3 ... see this page in the wiki explaining the version history (http://wiki.oscdox.com/version_history).

Hope this helps a bit towards solving your Authorize.net issues ...


12-30-2009, 11:21 AM
Your almost there!

After the checkout_confirmation page on your test order you should be taken to Authorizes SIM gateway page to enter in the credit card information. the url looks something like this...

https://secure.authorize.net/gateway/transact.dll (http://www.oscmax.com/forums/secure.authorize.net/gateway/transact.dll)

In regards to (14) The referrer, relay response or receipt link URL is invalid.
what did you specifically type into your box in your authorize.net page for relay uRL?
It's sensative.

also do you have ssl enabled on your site?


12-30-2009, 11:27 AM
re: also do you have ssl enabled on your site?

No, not as of yet...nor did I set up the cart yet for SSL

Could this be all it is?

12-30-2009, 11:39 AM
you "should" have ssl on the oscmax site for (IE8 and IE7 pop-up-window reasons) after processing the card - but you should double check to see what your relay url is set to in authorize.net thats important.

I think whats happening is that authorize thinks your url relay is going back to a https:// checkout_process.php page when its suppose to be catching http://chec... instead.

12-30-2009, 12:05 PM

It should not matter if you are using v2.0.3 or v2.0.4 as the only changes between these versions was the removal of the following files from the admin section.


However, I think you are using 2.0RC3 which is quite old now ... and different from 2.0.3 ... see this page in the wiki explaining the version history (http://wiki.oscdox.com/version_history).

Hope this helps a bit towards solving your Authorize.net issues ...



Yes I was, 2.0RC3 and thanks for your help !! And processed a transaction w/out a single problem back on :
Transaction ID: 2752529158 Transaction Status: Voided
Settlement Information Settlement Amount: USD 0.00 Settlement Date and Time: 15-Dec-2009 18:22:24 Business Day: 15-Dec-2009 Batch ID: 112258502 Authorization Information Authorization Amount: USD 1.00 Submit Date /Time: 15-Dec-2009 06:43:50 Authorization Code: 726401 Reference Transaction ID: Not Applicable Transaction Type: Authorization w/ Auto Capture Address Verification Status: No match on Street and Zip (N) Card Code Status: Matched CAVV Result Code: Not Applicable Fraud Score Applied: Not Applicable Recurring Billing Transaction: N Dynamic Currency Conversion: Not Applicable Partial Capture Status: Not Applicable

B) So, I simply figure time to upgrade to the 'latest-greatest'.. Like an idiot? I wiped it clean...and started fresh...as it was to be a new cart.

C) Everyone is telling me It works fine, extensivley tested yet I am saying it is not working with the 'installed' out of the BOX AIM CC module.

D) I finally decided (late last night...to go and then install the OSC version....and am having the same error.

E) I have also found file differences in /fallback .3/.4 etc... where lines of code are way out of whack as compared to RC3..and that the Payment Module for AIM is not the same either.

F) I have reported it to Michael also...

G) So, I also am seeing > (the search prhase) Authorize.net AIM Module

Search Form (http://forums.oscommerce.com/index.php?app=core&module=search&do=quick_search&search_filter_app)[forums]=1

That others with osc are having problems.."out of the box"...and I know this version? Is based on that...yet modified (not be me, nor do I really know where to start to look)...but am being told it works?

There was also a last year post by someone using osCMax

H) HELP!! (smile)...as I really don't think...nor have I spoken with anyone up here this past week...that actually is using AIM 'out of the box' here on 2.0.4 please?

I) I ?? Well, I think really this is something that I hope Michael could look into? As if "this core" is (and from what I see) cloned...etc... And the OSC folks...having problems...from 12/19/2009 (last week) (and I had pointed it out)

I just can't believe...what I keep getting told...that there is nothing wrong with it?

Again, thank's all for your help...but something is wrong with this picture. :-)


12-30-2009, 12:35 PM
In regards to your SIM test,
trochia what does your config.php look like - please post as the...

(14) The referrer, relay response or receipt link URL is invalid.

is related to how your config looks. Also, if and what your relay url is set to in your authorize.net account, which you haven't answered me back yet.


12-30-2009, 12:44 PM
Thx again, BH... Everything now is 'cleared' in Authnet for relay response...sorry, as I was in chat with them when I answered you last.

I wiped the cart again clean...deleted the DB...Downloaded/exploded and starting fresh one more time with 2.0.4 'out of the box' :-)

Uploading now..

12-30-2009, 01:07 PM
This will be Step-By-Step, results of "out of the box"..sorry for multiple posts...but it says I have used 10 images etc.

Never mind, converted to TEXT...and all have green Checkmarks.

Server Capabilities
PHP Version 5.2.8

PHP Settings
register_globals Off
magic_quotes Off
file_uploads On
session.auto_start Off
session.use_trans_sid Off

PHP Extensions

12-30-2009, 01:08 PM
New Installation

The webserver environment has been verified to proceed with a successful installation and configuration of your online store.
Please continue to start the installation procedure.


The installation and configuration was successful!

12-30-2009, 01:18 PM
AIM Module set..at checkout =

Payment Method Credit Card (Processed by Authorize.net)

Entering data

Press Confirm = There has been an error processing your credit card http://mynotify1.com/204/images/pixel_trans.gif Please try again and if problems persist, please try another payment method.
Now, into AuthNet=
Search by Batch
Help (https://account.authorize.net/UI/themes/anet/merch.aspx?page=search#)

Search Criteria: Payment Method [ ALL ] ; Transaction Status [ ALL ] ;Settlement Date [ Unsettled ] ; Show [10 results per page]

Click on a transaction ID below to view transaction details. Click on any column heading to sort.
No records found.

They have told me, and I know I am not hitting the gateway..

Hence? The module seems to be not working?? "out of the box"

12-30-2009, 03:12 PM
You need curl SSL for Authorize.net AIM to work. I've used Aim since 2003 but I did run into a problem last year when I was switching from the old AIM module. I won't go into all the details but the bottom line is I corrected it by getting a new transaction key. Anet has some troubleshooting files that you can run as a single php page from your domain that get all the osc stuff out of the loop that might help you.

Also, I modified the AIM files and this is what I've been using without a problem. You can find the post here and see

12-30-2009, 03:17 PM
John Thank you...right now running a recompile of apache on my srever...even though I know that is/was not the issue...but being "methodical" (smile)

curlSSL is/has been enabled...

Thanks for the file...will give it a run !! When this completes. The old AIM module...worked fine in RC3 for 11 months now...and that cart was back in 1/30/08

I hope this does it.

And thx again.


12-30-2009, 03:35 PM
Jim, I ran into a similar issue that really baffled me when I changed from the old AIM module also. Get a new transaction key from Anet to use and I'm positive the modified files I posted work, but they worked before I modified them but only after I got the new transaction key.

The old module works somewhat differently and I couldn't use my old transaction key with it. Since I had my live site running on the same server as my test site and the key was working on the live site it took a while to figure it out but the Anet test file helped narrow things down. I even tried using the old module which I knew was working on my live site but wouldn't work on the test site. So, I guess I understand your frustration:)

Is this problem on your live site, or a test site?

12-30-2009, 04:11 PM
LIVE, now I am DEAD (sigh)

01-03-2010, 02:50 PM
John and BH...

OK, I installed SSL and still nothing..

BH, what return strings? I forgot to mention...that that link you gave here on the threads...did nothing..

I have tried everything under the sun..
Authorize.net PAYMENT MODULE PROBLEMS - osCommerce Community Support Forums (http://forums.oscommerce.com/topic/302972-authorize-net-payment-module-problems/)


PS...John, I have not tried your files again..

It has to be in FORM SETTINGS and response strings...some say leave it blank...some say fill it in.

It now takes money in Authnet in 2.0.4 as I backed out all but 2 check boxes in Authnet Form settings ...

But will not give me a "order" in the danged cart.

Thanks again...and getting closer?

01-03-2010, 03:27 PM

Autherize.net is working/processing but reads error&#33; - osCommerce Community Support Forums (http://forums.oscommerce.com/topic/313841-autherizenet-is-workingprocessing-but-reads-error/)

Man, so many different people on OSC had so many different problems..

Frigging MD5 HASH just removed..as you can't remove it from AuthNet side..

His above post...I did not do anything as far as setting FALSE for sessions.

Thanks to all for all help.. I am for sure going to get this into the WIKI so no one has to go thru this.

First, I need to get back to the coupon deal now.

01-03-2010, 05:49 PM
Sorry all. I didn't mean to disappear, but I have not been able to get on oscmax.com for about 2 weeks. At first I thought the site was down, but now I'm not sure as I got it tonite through a proxy server. Were there any problems with the forum here? Did the site go down? It still seems buggy.

Anyway, I got AIM to work by changing settings in my Authorize merchant control panel. If you do not have all the settings right it won't work. It will get through but stop your cart from finishing the checkout process.

Go to Account > Virtual Terminal Settings.

Make sure the Field Name boxes are all checked in the View/Edit column, so that every option that is configured for osCMax's checkout is included. I have them all checked as it can't hurt anything and ensures it will work.

Under Business Settings, I set the Transaction Cut Off Time to 11:59 pm as well to allow orders late at nite. You may not want this, but I do on my site.

Under Security Settings, make sure Card Code Verification is turned on as it is included in osCMax.

Set the Daily Velocity high enough to allow transactions to process. I initially thought this was # of transactions daily per credit card, but it is for # of transactions from all cards per day. Very Important distinction as it will stop your checkout from finishing!

Apparently, if you're using MD5 Hash you just enter a word in there and not an encrypted password. I did that as well and it is working fine.

Do all these things and everything should work fine for you.

01-03-2010, 05:57 PM
Thx for the reply !!....lol... That was not the issue for me...

Trick is to Xnay the MD5 hash for sure...just leave it blank...and works fine.

Thing is, once one is recorded the first time in AuthNet...you can not REMOVE it...so therefore, I was under the impression the cart needed it.

No, I have not noticed any site errors or downtime on the forums.

And in my end of VTS...All is working with these NOT CHECKED>
Recurring Billing Transaction
Card Code
Also, I have shipping blank...as I will be using a DL item. (I hope)


01-04-2010, 06:30 AM
The MD5 is for the SIM module and isn't needed for the AIM because AIM connects using CURL SSL so it's already encrypted. Authorize.net has an online help manual that states that so I was a little puzzled why it is in the AIM module other than it's easier and faster to make them that way.

FYI, there is a 2nd version of the AIM module available on the main OSC contribution that has one line added to it so you can add this yourself.

Around 382 find this

curl_setopt($curl, CURLOPT_HEADER, 0);
add this after it

curl_setopt($curl, CURLOPT_SSLVERSION, 3);

01-04-2010, 06:39 AM
John and all...thx again for your help....

I am not going to touch a thing now in that...lol...just awaiting now to get get the issue with the Coupons resolved in the 2.0.x series.

Bug is reported, workaround given? Not sure if it is applicable to the series as it's RC3

Really should not have to attempt it, (I feel) as being the 'released' version...and any fixes...now going into a 2.1? Which is beta...

One feels that the simple fix in 2.0.4 and a simple re-zip of the package would eliminate things.

Thanks again to all...and if Authnet had a way to remove the MD5 entry...instead of just a CHANGE (it does not allow blank) after initial input..this would have been resolved a week ago+


01-07-2010, 11:48 PM
all sounds good but is there a setting to accept the changes of an existing order and existing price before it is captured by authorize.net? or does everyone who use AIM have to run a 2nd order (reorder everything) all over again for the smallest changes on an existing order?

01-08-2010, 03:35 AM
BH, I am a little confused as to what you are asking?

Are you speaking along the lines of once your customer places the order...that should they come back in and change it?

The only thing I can think of...would be to SET to "authorize only" and then you have to manually run it...and I guess along the lines of "wait and see" until they are done? (the customer)